requesting assistance -- Firefox plugin needed?

6 posts / 0 new
Last post
Anonymous
Anonymous's picture
requesting assistance -- Firefox plugin needed?

Hello, All - I'm a new member who has a problem I can't figure out.

I'm setting up a new computer. I use Firefox and when I downloaded it, I got version 2.0, which is pretty new. When I try to view Africam, it opens the space on the page, but before it actually can launch the player, I get a Firefox notice that I need to download a plugin.

What I get is the little green jigsaw puzzle piece and the message, "Plugin Finder Service: No suitable plugins were found. Unknown plugin (video/x-ms-asf-plugin)". There's a button to click to install the required plugin but it just takes me back to that "no suitable plugins message".

I know the cam's up because I can watch it fine from Internet Explorer on the new laptop computer, AND it works with Firefox (version 1.something) on my desktop computer. Both computers are running Windows XP (Home on the desktop, Media Center on the laptop).

I've Googled "video/x-ms-asf-plugin" but instead of finding an actual plugin, I just get discussions that refer to it. Flash, Java, and ActiveX are enabled on the machine.

Does anyone know what plugin it wants, and where to find it? Or is this perhaps a known issue with the current/newer version of Firefox?

Thank you in advance!

Anonymous
Anonymous's picture

(Looks like you were making your post at the same time I was editing mine. Smiling )

It's a puzzlement, alright.

Anonymous
Anonymous's picture

"jan001" wrote:
Katja - Thanks for the suggestion but, alas, that wasn't it. I had downloaded the Flash player last night, and gained the animation on the ads, but not the cam. Just to be sure, I just downloaded it again but got the same results, or lack thereof.

I do appreciate the responses, however -- if you think of anything else, don't hesitate! There's GOT to be a way around this.
Jan
Hmm, maybe a security issue? Should be just Windows Media Player, which is obviously OK, since it still works in FF 1.x. It's not a firefox 2.0 issue, I've run it there on win XP, though it does flicker, which isn't acceptable when I'm multitasking..

Anonymous
Anonymous's picture

Katja - Thanks for the suggestion but, alas, that wasn't it. I had downloaded the Flash player last night, and gained the animation on the ads, but not the cam. Just to be sure, I just downloaded it again but got the same results, or lack thereof.

I do appreciate the responses, however -- if you think of anything else, don't hesitate! There's GOT to be a way around this.
Jan

EDIT: There is a way around it and I've got it now. I still can't play the stream from within the site using Firefox, but I can open it in Windows Media Player using the mms URL, for which I've now made myself a shortcut on my desktop.

Nevertheless, if anyone reading this knows or suspects the cause of the problem, I'd still like to be able to view the cam from within the site -- this is one of those things that's going to keep tip-toeing around my brain. Sticking out tongue

katja's picture
Offline
modsquad
Joined: Feb 17 2006

"jan001" wrote:
Does anyone know what plugin it wants, and where to find it?
I think the one I had to install was Adobe Flash Player 9...

katja's picture
Offline
modsquad
Joined: Feb 17 2006

Hello jan001,

I also installed Firefox 2.0 on a Windows XP computer last week.
Like you I got a little green jigsaw puzzle piece and a message that said I needed to install a plug in.
But the plug in was just for the animated ads on the website, the cam worked fine without installing the plug in.

So I had no problems at all launching the player and watching the cam.
I'm afraid that doesn't help you much. Puzzled

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.